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ModelSim Simulation Tool
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So far we have seen waveform analysis for combinational and sequential circuits using
modelsim for simulation. The functional simulation was quite easy although it was bit
difficult to view the waveforms in real time. We will summarize this modelsim
commands one by one and also see in real time, although it will be little difficult for you
to view. Same windows are once again made it much made bigger for you to view more

clearly.
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Modelsim command swmnary

. Double click on icon - on your desk
top. Main Modelsim window and Welcome to
Modelsim window open.

. Click on "Create a Project” in Welcome to

Mcdelsim window for a new project. Create

project window opens. Type seq ckts in}

.
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To start with as a first time user you will have to first create your project. First thing you
have to do it is right on your system desk top which is this what you see is a desktop here
first thing that you had to is look for the modelsim icon here and double-click on this in

order to invoke the modelsim simulator.

You see a window opening here it says modelsim se “5.5” d you will get a window here
followed by one more window this one you can see here the bloated up version of this is

here you can see this.
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Precisely this is what you have. | will zoom it then show you. There was another window
opened besides that one this is the main menu that you have. This is the opening menu.

Let us zoom it in order to have a clearer look here. This is the main modelsim window.
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For the time being ignore this, this is the next menu that you had already seen, we have
different options here. Let us say, first, you want to create a new project, then you use

this create a project.

If the project already exists you need to open that project using this. If you want to view
the documentation which is available as a help in help mode then you can use open

documentation.
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Of course, this one will open the internet. You can view the documentation in pdf format.
On the other hand, you do not want to create any project straight away. Enter the
modelsim you can enter through this also. This is the main modelsim window that thing
is right here.
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This is the modelsim window. Let us go in to these details later on. First, just get a feel as
to what it is. We will describe all this in short while. If you want you can zoom this again

or it is already zoomed.

Now, what we had is this, we had one more that is welcome here, you can locate it here,
so that you can see both the windows. This is what we have seen in zoomed fashion. Let
us say, we want to create a project. You just click on this.

It is asking for the project name. You can also browse different directories here then go
over to the desired directory where you have located all your verilog files. For example,
let us say, we will go up further. It is in d directory user here. Then there is one more
directory called dvlsi then another directory called etc.

Suppose we want to locate it here. We will say open. That is what you have got here is,
you can see this window in a minute before that we can key in here. Let us say we want

sequential circuits, so we give apt name there.

We will give sequential circuits, underscore circuits. This is the project name that we are
going to give. This is the directory in which all the verilog files are located for this

project. Another important thing is it should be in a work directory. It should not be in



ieee directory. It should switch over to work directory here. If it is not there you may
have to create project. What happens it reports a project of this name already exists and

do you want to override it, you can say ‘yes’ or even ‘no’. Let us say Yyes.

What has happened here is you have a project here, library here; prior to that what that
create window was, so we will just have a look. The create window is actually this. We
had browsed through different directories; then put the desired directories; selected the
directory we wanted; we keyed in sequential circuits; here also ensure that default library
name is work then pressed okay. It reported that it is already there that is we pressed yes,

having done that what happens?

This is the window. This is the real window. So prior to that, we had had a summary here.
Let us just read through this to make sure whether we have already gone through the step
by step procedure. These are the modelsim command summary.

The very first thing was double-click on icon. This is what we have done. This is the icon

on your desk top main modelsim window.
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top. Main Modelsim window and Welcome to

Modelsim window open.

., Click on "Create a Project” in Welcome to
Modelsim window for a new project. Create
project window opens. Type seq ckts in
Project Name menu, and alsoc type the
desired location of the directory where
you have your Verilog files stored in the

Project Leocation menu. Make sure “work” is:

- - - . .- ~

.

Then we had clicked on ‘create a project’ in welcome to modelsim window for a new

project. But it already existed. So it gave a warning. We accepted that. When you create



for the first time you would have had a smooth flow here, because it already existed. This

was slightly different.

But anyway for a beginner, this is the best approach. You just follow step by step and you
would have learnt within no time. Entire modelsim is condensed in just sixteen or
seventeen points. It will be a ready reckoner for you to use. It will be very useful

especially, for a beginner.
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desired location of the directory where
you have your Verilog files stored in the
Project Leocation menu. Make sure “work” is
entered in Default bef;ty Name. Click on
OK. In the Main Modelsim window, click on
Library on the bottom left.

. In ModelSim> prompt, type “pwd”

Default Library Name that you keyed in,

say,

Click on create a project in welcome to modelsim window for a new project. Create
project window opens here. Then type sequential circuits in project name menu. Also
type the desired location of the directory where you have your verilog files stored in the
project location menu. This is precisely what we have done, overwritten actually.
Although it already existed we cautioned to make sure work is entered in default library

name. This also we have seen then said click on okay.

In the main modelsim window click on library on the bottom left. This we have not
covered. We will just see here. You see two windows here. If you see this simulator
window you can clearly see a library here. But it is in simulation mode because it had just
completed the loading the sequence of circuits which | had already tried out. That is why

we are in this position.



If you had created earlier, you would have got here library one more here. | think it is a

process. We will just see what it is library project right.

Click on library here so you see in library work pops up. There are other things, ieee
etcetera if you put any files that are created here it will be written, overwriting some of

this system files, it will have corrupting effect on its function

Make sure it is in work directory not in any other directory. Once you had selected this
you can see so many other files. We have already done two inputs AND gate earlier all

those are listed here including a sequential circuits.
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Library on the bottom left.
. In ModelSim> prompt,

Default Library Name “that you keyed in,

say,
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in the prompt tc get a display of all the
files in the current directory.

. In main window, coclick on “Design ->:
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Next we will go in to the command summary. We had just clicked on library on the
bottom list. The third step is modelsim prompt type pwd default library name that you

keyed in another directory in this system it is different.

What all we want to do is just type pwd as you use UNIX command. Here it is not purely
UNIX probably you can see directory it is a UNIX command. There might be some

difference let us see here.

In the modelsim window here | will just type pwd let us see what happens. It is reporting

that d user ram dvlsi underscore design etc.



This is precisely the path we had given earlier at the time of creating the directory. If you
want to know the contents in the files in the directory, type dir pull make it bigger and see

the content.

It has listed all the files including sequential files that you have here; similarly
combinational circuits are also available in this. Here, type directory in the prompt to get

a display of all the files in the current directory.
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in the prompt to get a display of all the

files in the current directory.

. In main window, click on “Design =>
Compile”. “Compile HDL Source Files” menu
opens. .Doublo click on the desired test
bench, say, "seq ckts test.v". The test
bench and the design will be compiled.
Errors if any will be reported on the main

window. If there are errors fix them.

- haha SN

.

In the main window click on design then compile. We have already created the files; I am
assuming that you are already familiar with the editor which | have not shown. It is

deliberate because it is too simple a thing that needing a demonstration.

Simplest thing on windows can be a notepad or wordpad which is just child’s play you

can pick it up if you are not familiar.

Here we had to use the editor, create the source files test benches on locate in the same

directory that we have already seen in main window. Now click on design compile,

Having had all this source files next step is to naturally compile this files. Compile HDL

source files menu opens with this condition. First we will execute that, this is the



command thing here you can either key in the command. For example, for compile you

can type vlog then file name with a space.

Another alternative is click on the menu here, for example in design menu click on

compile. Another file opens we will see a zoomed version of this.

We have all the test benches including designs; sequential circuit test bench is here you
can click it. Then say compile this is one faster approach simply giving double-click. You
do not have to press compile. On the left here on the window | am double clicking on

sequential circuits underscore test.

Now you see it has done the compilation. For example, compiling a module sequential
circuits it has taken the design first then it has taken compiling module sequential circuits
test bench. Always the lower ones are compiled first then it moves up to the top which
happens to be here. This module is in work directory.
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You have a top level module name also here this is not dot v or something; this is also an
important thing that you should take care while loading this design. So far we have done
compiling the design; next step is to load the design. Prior to that let us view the window.

So this was the window here all the commands, we keyed in right here and used this



design, we clicked on this then clicked on compile, here you can see that window. You
can see it once you click on compile in the design. You have compile hdl source files

opening out, remember this was the last directory in which our files are located.

Here you see the list of all the files here, what is of interest is the sequential circuits.
Unfortunately this is truncated here it is actually test sequential circuits underscore test.
This is the design sequential circuits. We cannot move this; | also made the mistake but
drew a line because we are in the paint. If | draw a line that is not the real window; the

real window is here.
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We have already done the compilation and dismiss this window by saying done. We will
come back to this once again. We have already seen that we need to just double-click this
then press okay. | mean compile or if you double-click straight away compile, which you

can see in this main window here.

Anything of interest, once we have done the compilation there were no errors. To make it

simple for you I did not inject any errors. Now we will cover synthesis tool, here also you



get involved with compilation. Naturally, error will be encountered at that stage, not only

in this stage of compiling but also in while loading. We have to fix them at every stage.

Similarly, when everything is satisfactory as far as functionality is concerned, you will
move on to the synthesis tool where in you do logic optimization as well as map it on to a

target device say a particular fpga.

At every step as | mentioned you will be encountering plenty of errors to start with, as a

beginner you will have to fix them.

After we take up synthesis we will club both modelsim synthesis together create

deliberate errors so that you can quickly learn to overcome that by practice.

Next we need to load the design. Prior to this we will go to the live window. Once again
you click on design then say load design; after compile click load design a load design

window pops up.

In this you will have that sequential circuits test, there is no dot v. Earlier | pointed out
here it was pointing to the top module as sequential circuits underscore test that is listed
here. Mind you it is in work directory, we double-click once again here, make a single
click in which case the same thing will be copied here, then add, this load will light up.
My shortcut is double-click here straight away so you can dispense with pressing add it

appears here.

Now you see work dot sequential circuits underscore test the top module is sequential
circuit test but you are working in a directory called work separate directory. This is
mandatory as | mentioned earlier how it is precisely the same here. That is library here is

out of project library sometimes if you click here you may not see this.

Make sure that is in library. Next step is to load, in this case press the button load. Here it
has successfully loaded.
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Loading work sequential circuits underscore test, loading work sequential circuits design

it loaded the top one first here then followed by the design, you can also see here.

The top module under that design is there so it has loaded here. If it were successful it
would not report any error. If there are some bugs in your code then it may report error.
Although, it has come clean through compiling, errors can be reported even while

loading.

Before this let us have a look at the command summary where we had gone several steps

ahead. Let us see in main window click on design compile that we have done already.

Compile hdl source file menu, opens double-click on the desired test bench say sequential
circuits underscore test dot v. The test bench and the design will be compiled; errors if

any will be reported on the main window. If there are errors you will have to fix them.
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bench, say, "seq ckts test.v". The test
bench and the design will be compiled.
Errors if any will be reported on the main

window. If there are errors fix them.

. Otherwise, click on “Done” Click on

"Design => Load Design” in main window.
"Load Design” menu opens. Double click on
the desired test bench, say,
"seq_ckts_test” followed by "“LOAD". The;

.

Now click on done we have already seen this; we are merely formalizing the reading of

this to make sure that this really serves you straight away. Click on design then load

design in main menu.

sequential circuits test

Load design menu opens double-click on the desired test bench say

followed by load. The test bench will be loaded into the simulator.
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. Click on main menu, “View => Signals"”,

Signals window opens. In that window,
click on "View => Wave => Signals in
Design”. Waveform window with the listing
of all the signals opens., X-axis of the

waveform gives the time in ns.

. Click on "Run -all” menu on the top second

row on the right. Click on "Zoom Full”:




Next we will have to load the design and compile the design. Next logical step is to view
the waveform, to do so there is a menu called view. Click on that menu option followed
by a sub menu called signal. Click on main menu view signals then signal window opens,

you can have a look at it.
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This is the main modelsim window, it has been loaded you can see partially here. After
view, you have a signals window opened. When you click on the signals, this window
will open, where you can see so many ios listed here. It is a very exhaustive list you can
drag this down, then view all this. Do not care x here, it means we have not started

running the simulator.

When you run the simulator you should get the waveforms, we have only loaded the
design. It is showing do not cares here because no valid data is available; this is nothing
other than data at any point of time. Wherever the cursor is located on your waveform at
that position whatever is the actual data for a particular signal. For example, if it is d
signal that d signal actual data will be reflected here. This is the signals window here the
main window is this. Going back to this view, you can use this also in order to open the

wave first then select the signals or you can open this and open in this form also.



There are two ways two approaches to open the signals window, first or wave window
first. Let us see live window right now. Here there are so many listed source structure
variable signals list process wave. Either you can open from wave here or signals this will

be a short cut.

I will open signals in the view so you have seen precisely the same signals window
opening here, in this you see one view, there are three options one option one is selected
signals in particular region. Or you can select some of the signals here or in a particular
region you can select those signals this will not be exhaustive list of the signals. If you
want exhaustive total totality of the design reflecting then you should press signals in the
design. Now let us see we have had another window opened here. We do not require this

signals window any longer you can just dismiss it off

If you want you can just grab here, make it bigger and then put it anywhere here. Let us
say we put it somewhere here. We grab this line also put it here so as to read the signals

listed very clearly.

You will have more viewing space here; you can drag this and see the sequential circuits
underscore test is what is mentioned here. It says d a b c, if you remember we have
handled all this signals earlier. Clock reset n hold shift in one in two trigger so on, the

order may not really satisfy you.

You can relocate this order which will be seeing little later. Prior to this we were in view
signals window, click on view wave signals in design. This opens waveform window
with the listing of all the signals. This is the waveform window what we have already

seen in x axis, you have nano seconds mark.
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. Click on "Run =-all” menu on the top second
row on the right., Click on "Zoom Full”
menu to view all the waveforms. Other zoom
options such as “Zoom In", "“Zoom out”,
"Zoom Area”, and "“Zoom => Zoom Range” may
be used to get the desired view.

. Locate the signal, say reset n, and click

on it. It will be highlighted. Click on

the highlighted signal, drag up and leave |

We have opened the waveform window now it is right time for running your simulator.
There is a run all command, first read this. Then click on run all menu options on the top
second row on the right, click on zoom full menu to view all the waveforms. Other zoom
options such as zoom-in, zoom-out and zoom area, zoom range may be used to get the

desired window.

We can first click on the run all command, this is the major command here, 1 mean you
can either key in as | mentioned or it is all menu driven. You can use run here, also notice
100 here it is called run length. You can change it if you want. If I click on top arrow here
it has advanced to 110 nano second this it will be difficult for you to read. If O click on
this lower one it comes back to 100 nano second it can go down.

You can program the units to go up or down. It says run here then followed by continue
to run and run all which will start running. You also had a wave file opened already here.
Also you have the very same thing for example if | give this run all, it will spontaneously

run, see the waveforms right on the screen.

I will click on this let us see what happens. You can see the whole thing becomes alive
with waveforms here it also opened your sequence source file that is, the test bench

sequential circuits underscore test.



(Refer Slide Time 29:34)

It is actually a enter file, you do not really need it since you have already seen. You can

remove this window here.

These waveforms are so small that you cannot see properly except for very faint lines.
There is one zoom-in here so let us see. | do not have another window which is zoomed

version of this.

I might have had in another place I will have to hunt for it. Before that, | will just quickly
explain this basic thing that is one plus zoom-in command, it is a lens like thing with a
plus mark here. Similarly, a minus here if I click on plus you see that the waveforms are
increasing. It goes every time, zooms by a factor of two similarly downwards also. With a
minus thing if you click on this one it says zoom full, there is one more in between this is
zoom area where you can mark an area and zoom. | will just click on this zoom full here.
Entire simulation has been condensed to one screen therefore you see all crowded signals

here.

We have one more here called zoom area let us say we are interested only up to this. We
zoom from here, only that portion has expanded. For example, every time you had to

press that up to this to the last waveform.



It fills the entire screen. In this fashion you can zoom. Let us go back to the text that we
have. There is one zoom area that is what we have seen zoom-in zoom-out, zoom range

may be used to get the desired view.

In zoom, let us see the waveform here once again you have one zoom menu here. We
have just now seen area marking zoom area with mouse button. Another thing is range,
suppose you want let us look at this here, you see the cursor has changed. | can mark as |

had done earlier, so it has zoomed in the area that we have marked.

On the other hand, if you want zoom the entire range if you click on this one, another
window pops up called wave zoom a start end time is marked here. For example, we want
zero start time here. | have given say some 26 nano seconds. So 0 to 26 nano seconds
have to be shown, time axis is right here it is marked in nano second this is 100 1 21, 40

SO on.

Let us see when we press apply then you can see here 0 to 26. So this is 26 that is, it is
difficult to capture which | have explained. This is over so you can say just okay. We
have already seen in zoom range. Next thing is let us see how to place a different
waveform. Waveforms at desired point, you want to check the functionality for a

particular a part of your design.
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options such as “Zoom In", “Zoom out”,
"Zoom Area”, and "Zoom => Zoom Range” may
be used to get the desired view.

. Locate the signal, say reset n, and click
on it. It will be highlighted. Click on
the highlighted signal, drag up and leave
it at top of all other signals. Likewise,

you can drop all other signals belonging

te a function next to the first signal and;




We can locate these signals close together then view this waveform. Locate the signal say
reset n click on it if you want to locate this signal click on that signal. It will be
highlighted click on the highlighted signal drag up and leave it at the top of all other
signals.

(Refer Slide Time 34:26)
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We will just have a look, I will first read this likewise you can drop all other signals
belonging to a function next to the first signal and so on. You can also use cut or copy

one or more signals, then finally paste all in edit menu at the desired place.

You can also use edit find for locating the desired signal for there are various signals.
You can locate any of signal by saying find as one example place reset n clock d g and g
underscore n one below another then highlight all these signals by clicking on first signal
followed by shift plus clicking on the last signal. You can highlight all this.
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"Edit” menu) it at the desired place. You

can also use “Edit => Find“ for locating
the desired signal. As an example, place
reset n, clk, D, Q and Q n one below
another. Highlight all these signals by
clicking on first signal followed by
"Shift + Clicking” onlého last signal.

. Click on “Format => Height", Wave height
window opens. Key in 50 followed by

The reason for highlighting is we want to change the height. Let us go back to the wave d
is here this is what we wanted. Reset is here. Suppose you want reset let us say right on
top, click on reset then holding the mouse button drag it right on the top and leave it

there.

The reset n has come over there; this is not the only way you could have cut here. Then
pasted here that is another way whatever signals are there right on this page within the
vicinity you can drag like this. Otherwise you may have to use the find which will do for
signals not available here. Let us say we want next clock so we will put it there yes. Next

we have put a reset n clock here then there a d input is already there here.

What remains to be done is only q g underscore n so if | am to search here it keeps on
going like this waveform after waveform. It may be difficult although | am able to spot
here right with a large design it will be very difficult to spot. We straight away use find

so this is also like if you had used wordpad, you would have precisely used edit find.

Let us use the same thing. The window opens here let us key in g here. Sometimes it does
not spot it out perhaps some bug is there in the software, sometimes it works, you may
have to try probably couple of times. I do not know the reason in fact modelsim has

already listed in help if you go lots of bugs reported, prior to which they have fixed.



Obviously some more bugs will be encountered from time to time. It would be good
practice for you to report to them so that they can fix for the future people who use. We
will make one more attempt if it does not click we will go on and pick it up from there
right.
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Let us say edit find there is also search, otherwise we have one more signal called g
underscore n so we will hunt for that. That seems to be some bug evidently right so now

you can dismiss this window. We have fortunately g g underscore n located side by side.

It is once again the windows way, press control select the other signals for this two on the

other hand we wanted from here to here.

You click on the other signal so any group you can go like this; you can keep on going
here after. You may have to use a control let us say cut paste else where it will be very
easy to do that. Now we will confine our attention to these two signals; we will now cut
here. In fact there is a cut available here a scissors here, so we will paste it here the point

is we wanted here.

We will just paste it here what all we have is reset clock d g q underscore n these are all

the signals that we want. Let us highlight them; once you highlight we wish to increase



the spacing between that unfortunately in this software unlike signals can or ut of

cardons. As | mentioned before you cannot have the height of the waveform manipulated.

What all you can have is place them apart more and more apart. What we do is there is
one format and height here .What you do is the height is in 17 pixels; we will make it let
us say 50 or 60 or even 90 right!

Now apply immediately you see whole thing is changed right so that you can you can say

okay then you can view all the waveforms of interest here.
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Fortunately, all the waveforms that you need are exactly fitting this complete screen and
analysis you have already learnt. I just want to show you step by step procedure of

invoking different commands.
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"Shift + Clickang” on the last signal.

. Click on "Format => Height”. Wave height
window opens. Key in 50 followed by
"Apply” and “OK". All the selected signals
are spaced by 50 pixels. Height of the
waveforms, however, remains the same.

.Click on "“Format => Radix => Binary or
decimal or hexa decimal or octal as per

o your requirement. All selected signals are:
i 265

Going back to this command,; click on format height wave height window opens right key
in 50. We had keyed in 90 followed by apply. All the selected signals are spaced by 50

pixels height of the waveforms, however, remains the same.

(Refer Slide Time 41:16)
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waveforms, however, remains the same.

10.Click on "“Format => Radix => Binary or
decimal or hexa decimal or octal as per
your requirement. All selected signals are
set to the desired number system.

.Use <, > arrows and so move the waveform

along the time axis. Analyze the waveforms

(timing diagram) to check the

functionality.




Next we want to select the format for each of the numbers. We may have a bus it may be
grouped as a single signal or it may be a binary signal. You had to select in what format

you want it to be displayed then you use this format

I will read this here click on format radix binary or decimal or hexa decimal or octal as
per your requirement. You can just select from that menu all selected signals whatever
you have highlighted those signals will only be set to this set to the desired numbering

system.

Use some arrows there at the bottom of the waveform so you can move them. There is
also a small block you can drag or you can click in between the blocks so as to move all
along the time axis. To move the waveform along the time axis analyze the waveforms,

this is the timing diagram check the functionality which is the real goal as such.
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functionality.

.Repeat 8 through 11 for all other
functional parts of the design.

.To save the waveform format, click on
Floppy disc symbol or "File => Save
Format”, and in the opened window, type
"seq ckts.do” and oclick "Save”.

.This completes one session. To exit the

Modelsim] click on "File => Quit” andﬁ

P a0 0

8 through 11 we had to repeat for all other functional parts of the design. If you want to
test other parts of your design you repeat from step eight to this last step here. Step eight
was selecting of the signals that we started with. We will resume this we will have a look

at that we have done here.



Let us say this reset clock d g all of them are single bit. You want to see one st this means
some symbolic way of representation, in format we saw one radix that is what we have
seen here. In this are listed symbolic, then binary octal decimal then unsigned also
unsigned is also a decimal number. You want to get rid of this sign; there is also a hexa

decimal. If you want ascii you can have default I think is symbolic.

Let us say here we want all this signals which are already marked to be in binary, so we
just click on binary radix format radix binary, so you can see that st disappeared in these
two cases. Now suppose | click the cursor here whatever is the actual state will be

indicated here, it is actually 0.

(Refer Slide Time 44:04)

This g underscore n 0 g is 1 here so that is what you see here at different points it will be

different it has gone one.

In this fashion you can click on cursor at different points and get the actual data displayed
here as | mentioned before. We will see some other signal which is other than set data we

have. Let us see this is also in binary.

Suppose let us say counter here as | said there is arrow here. If you click on this arrow the

waveform can be taken to the right.



You see 24 nano second etcetera; if you want move left here you can this patch of this

block you can move it for much quicker movement.

You can even press here it will in between this space, it will take you one screen at a
time. Similarly here, this counter let us say it is showing in binary, it is showing four 1s.

Let us set the format for that particular signal to unsigned, it was four 1s, so it

corresponds to 15 in decimal. If it is in hexa decimal it is zero f.

That way you can check at various things. If you want decimal number here it is
unsigned. So unsigned decimal does not make any difference else where it might make a
difference where signed number is involved. In this fashion you can go to any waveform

analyze going back to this.

What we have here is, up to this once you have done formatted all this. If you quit, you
have finished the job. If you quit the software waveforms relocated and all of them will
disappear. Next time you enter again you start from square one. In order to save, click on
floppy disc symbol or in the opened window type sequential circuits dot do then click
save. We will see all this would complete one session, next time you want to come in we

can start from where you left.
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"seq ckts.do” and click “Save”.

+This completes one session. To exit the
Modelsim, click on <“File => Quit” and
"Yes".

.If you want to use Modelsim again to

resume the same project, double click on

icon - on your desk top.

16.Click on “Open a Project” in Welcome to.
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There are another 3 steps here. | will first show this. We have a screen here you have
okay, in the waveform you see same floppy symbol if you press this one it pops out a

window here.

Here you have sequential circuits, so we can give an apt name here. Notice this is a dot

do file. You click on dot do file is an important thing.

You save it as sequential underscore circuit dot do, so you just save it here. Now we can
quit this window. This completes one session. If you want to use modelsim again to
resume the same project double-click once again it is same as one there shown earlier.
This time you had to use open a project in welcome modelsim window because it is

already created, make sure the directory is the same.
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16.Click on “Cpen a Project” in Welcome to

Modelsim window. Make sure that the
directory is the same as in 3 by clicking
on "Library” on the left bottom of the
main window and typing "pwd” in the prompt
field, Otherwise, oclick "File => Change
Directory” and select the desirad
directory and click on “"Open”.

17.Load the test bench as shown in 5. In the;

=
.
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As in 3 by clicking on library on the left bottom of the main window typing pwd to make

sure that you are in the correct directory.

Otherwise click file change directory, select the desired directory just like in windows.
Final step is load the test bench as in five. We have already seen loading of the test bench

here.



You go back to five it is simple to follow in the prompt field type do sequential circuit

dot do, then waveform will be invoked.
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17.Load the test bench as shown in 5. In the

prompt field, type "do seq ckts.do”, the
waveform we saved in 13. The desired
waveform with the previously set format is
retrieved. Repeat from 7 to continue with

other functicnal parts testing.

The waveform we saved in 13 will be this. The desired waveform is the previously set

format it is retrieved, if you do not do this the previous format is lost.

You had to save then retrieve it as for subsequent analysis because all big designs you

cannot complete the entire testing at one goal.

You may have to spread it over many number of days, this will tell you how to enter
create a new project as well as to open new project for which you need to save that
waveform file. Then repeat from 7 to continue with other functional parts testing which

we have already seen.

The step 7 is run is the basic thing so we will close this here. Here we have already saved.
This time we say open a project this is already there in the desired project in library. We
saw work here now we should load the design first. If you do not load the design you will

get error so do the loading first.

Now you can say do what is the waveform name we have given sequential circuits,

remember to give that extension do also then only it can do.



Let us see what happens it says it cannot open macro file, so we had to see whether it has
saved in that particular directory test dot do or not.

You can list this directory right here; you may not find it so we will look at this next time.

With this summary of modelsim commands are over. We will have a look in the next

class the problem we have failed to see, then will take up new thing called synthesis.
Summary of Lecture 28

ModelSim Command Summary

Next Lecture

Synthesis Tool
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