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Lecture - 32
Forming Portfolio with ETFs

Hello there we are talking about exchange traded funds as an investment up class and we
know that exchange traded funds are very much similar to mutual funds, but they are listed
and traded on stock exchanges. In this session, we will talk about how to form a portfolio

using exchange traded fund as an asset.
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Specifically, we are going to talk about an illustrative example of portfolio construction using

exchange traded funds, where the assets will be exchange traded funds. And we will form a



portfolio using our understanding of portfolio theory, but it will be implemented in excel

ad-in that is using solver we will construct a portfolio, where the assets will be ETFs.
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Data: Monthly closing prices of ten ETFs listed on a stock exchange (Dec. 2017 - Dec. 2022]
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1 Month g ETFO2 ETFO3 ETF04 ETFO5 ETFO5  ETFO7 ETFO8 ETFO9 ETF10 Rl.'
3 Dec2017 1234 1085 352 1020 718 289 9.78 9.93 268.00 216.38
Jan-2018 1275 1085 390 1123 852 313 9.99 1025 272.25 21638
Fed-2018 13.16 1229 419 1174 906 343 1009 1043 276.25 216.38
_5 Mar-2018 1338 1229 405 1104 835 322 1011 1045 273.04 235.88
Apr-2018 1338 1203 394 1135 810 315 1025 1059 278.62 233.77

Oct2022 1832 1256 374 1323 1002 212 1093 1096 286.04  259.19
Nov-2022 1942 1224 355 1305 930 219 1063 1082 28068 24221
Dec-2022  19.87
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To start with, we know that we should have some historical data, we know from our
understanding of portfolio theory that we need to have an understanding of historical trends in
risk and return for assets that are to be considered for constructing a portfolio or for creating a

portfolio of assets. Here, we have the monthly closing prices of 10 exchange traded funds.

Let us name them as ETF1, ETF2, 3, 4 till 10. We have data for 5 years starting from
December 2017 till December 2022, where these 10 exchange traded funds that are listed on a
stock exchange are selected for including in a portfolio. And these are the data on the prices
of these ETF, which implies that this particular number is the NAV or the price of that
particular ETF1 as on the last working day of December 2017. And similarly, for January
2018, it is 12.75, further it is 13.16 and so on.



Here these are the missing sales; basically, we have the data in a spreadsheet that we will
discuss later. But for now, we have the data set for all these 10 ETFs on a monthly basis,
where the prices are available for a 5 year period. Now, once we have the data, the next

approach or next step is to calculate the return.
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We know that to calculate the return, which is basically returns in terms of changes in

monthly closing prices. Here we will use this formula, where we have the return of an asset i.

So, return on asset 1 at time t, which is basically the monthly time period is based on or is
calculated on the basis of price of asset i at time t minus price of asset i minus time, into t at t

minus 1 with respect to the price of asset i at time t minus 1. We know this argument, we



have learnt it before, we have discussed in detail, where suppose at time 0, we have 100

rupees of investment and if at time 1, the value of this investment is 110 and we sell it off.

So, we know that return will be calculated as price at time 1 minus price at time 0 divided by
price at time 0. So, we can calculate this as 110 minus 100 upon 100. So, this tell us
percentage return or percentage change in price. Similar argument is used here, where we will

calculate the return on each ETF on a monthly basis.
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Since we have the data from December 2017, so first return will be calculated in January
2018. So, first return on asset 1 that is ETF1, ETF2 through ETF10 will be calculated in
January 2018 and subsequently we will find the return for every month for each of the 10 ETF

that we are considering here.
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Monthly returns: Change in monthly closing prices Ri.l = Pi .
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ETFO2 ETFO3  ETF04 ETFO5 ETFO6  ETFO7  ETFO8 ETFO9 ETF10

Month ETFO1

Dec-2017
Jan-2018 0033225 0 0.07955 0.10098 0.18663 0.163569 0.021472 0.032226 0.015858 0
Feb2018 0032157 0432719  0.074359 0.045414 0.06338 0.095847 0.01001 0.017561 0.014692 0
Mar-2018 0016717 0 -0.03341 -0.05963 -0.07837 -0.06122 0.001982  0.001918 -0.01162 0.090119
Apr-2018 0 -0.02116 <0.02716  0.02808 -0.02994 -0.02174 0.013848 0.013397 0.020437 0.00895

Oct-2022 0003836 -0.00397 0.005376  -0.0229 -0.00398 0 -0.00365 0.00828 0.00908 0.01759
Nov-2022 0060044 -0.02546  -0.0508 -0.01361 007486 0033019 -0.02745  0.01217 001874 -0.06551
Dec-2022 0023172 0035131 0.002817

004444 -0.0086 0.13242

-0.01787

-0.01109

-0.00481

0.00111
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This is the way we can calculate the return. So, this is the snapshot of the returns on 10 ETFs
that we have calculated using the price data starting from December 2017. Since we are
considering to calculate the return on individual ETFs by using the previous month's data and

change from previous month to current month as return.

So, the first return is coming in the month of January. So, here we have the return for ETF1 in
the month of January as 0.033225 that is 3.3225 percent. Similarly, next we will calculate the
return for individual ETFs accordingly and we will we will have a panel of a data set of

returns or rather monthly returns on 10 ETFs for a period of 5 years.



Now, if we are using this example, if we are implementing this example in a spread sheet
such as my excel then we know that we can use some sort of function where we can calculate

the change in price using simple function where we will have the price data.

So, here if we have this price data and these are the cells that we know we have. So, let us say
this is cell number 1, cell number 2, row number 4, row number 5 and so on and this is cell A
or column A, column B, column C, column D. We know that the first return on asset ETF1
will be calculated by using the price in B 3 minus B 2 divided by B 2. If we are using this
example in excel sheet then we will use this function to find out the percentage change in

price which is in the form of return.

So, this will be the a function for excel sheet implementation that we will discuss later. Once
we have the return, we know that to form a portfolio we need to have a set of assets which for
which we have to calculate the variance covariance matrix because we understand that
portfolio return can be weighted average rate of return of individual assets. If you could recall
the formula for return of a portfolio its basically weight of individual assets and return of

individual assets sum together.
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Monthly returns: Change in monthly closing prices R” = P
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ETFO2 ETFO3 ETF04 ETFO5 ETFO6  ETFO7 ETF0O8 ETFO9 ETF10 @J“{J
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Month ETFO1

Dec-2017 ZS“W‘I Gj WJ U
Jan-2018 0033225 0 0.107955 010098 0.18663 0.163569 0.021472 0.032226 0.015858 0 |

Feb-2018 0032157 0432119 0074350 0.045414 006338 0095847 0.01001 0017561  0.014692 0

Mar2018 0016717 0 003341 005963 007837 -0.06122 0001982 0001918  -0.01162 0090119

Apr-2018 0 -.02116 -0.02716  0.02808 -0.02994 -0.02174 0.013848 0.013397 0.020437 0.00895

Oct-2022 0003836  -0.00397 0.005376  -0.0229 -0.00398 0 -0.00365 0.00828 -0.00908 0.01759

Nov-2022 0060044 -0.02546  -0.0508 -0.01361 007486 0033019 -0.02745  0.01217 001874  -0.06551
Dec-2022 0023172 0035131 0.002817

004444 -0.0086 0.13242 -0.01787

-0.01109

~0.00481

0.00111
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But when it comes to the formula for portfolio risk which is variance of the portfolio, we
know that it is based on sigma asset 1 square weight asset 1 square sigma asset j square weight
for asset j square plus 2 into sigma 1 weight 1 sigma j weight j and rho that is correlation

between i and j. This is the formula for portfolio risk.

Now, if we have to calculate the portfolio and we need to know which assets are to be
included in a portfolio, then we have to have the variance covariance matrix in with us. So,

that we can use this variance covariance matrix to construct a an optimal portfolio.
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=  Annualized returns and annualized std. dev.: average return and risk

=AVERAGE(N3:N62)*12

ETFO1 ETF02  ETF03  ETFO4 ETFO5  ETFO6  ETFO7 ETFO8  ETF09  ETF10

Annualized Return 10.14%  419%  193%  612%  7.61%  198%  148%  172%  096%  264%

Annualized STD 10.85; 14.90% 186%% 2069% 23.11% 27.18%  590%  673%  507%  9.11%

=STDEV(N3:N62)*SQRT(12)
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Now, here we have the return and once we have the return, we can proceed further to
calculate the annualized return and standardized or annualized risk. Now, this is required
because for any set of data if we do not know the average rate of return, we cannot know the
expectations. So, we first calculate the annualized return and annualized standard deviation to

get an idea about average return and average risk on each of the 10 exchange traded funds.

So, in a simple way what we did was we found the total return of the return of series of
individual assets and annualized it by dividing multiplying it with 12 that is number of
months in a year since we have the monthly data. So, we find the average of all the returns for
individual assets for individual ETF and annualize it by multiplying it with 12. So, this is the
data that we get where we have for ETF the average rate of return is 10.14 percent per year

and annualized standard deviation is 10.85 percent.



For ETF 2 we have annualized rate of return as 4.19 percent and annualized standard
deviation is 14.90 percent, then we have ETF 3 where we have annualized return as 1.93
percent and annualized standard deviation as 18.69 percent and so on. We know that none of
the assets none of the ETFs has generated more than 10.14 percent of return in any case. So,
that is the highest return generated by this ETF during this 5 year period on an annual basis
and if you look at the risk then we see that this is the highest risk that ETF has carried or ETF

data has shown.

Now, with this understanding now since we were talking about implementing this example in
an spread sheet or excel we know that we can use the function of average from for all the
returns multiplied with 12 and similarly for standard deviation we need to annualize it since
standard deviation for all the assets put together on an average and multiplied with square
root of 12. And this way we should be able to find out the annualized rate of return for

individual ETF in this case ETF1 through ETF10.
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Correlations (pair-wise) across ts/: ies T =

=CORREL(SNS3:5N$62, N3:N62)

TF02 | ETF03 ETFO4( ETFO5 ETF06 ETFO7 ETFO8 ETF09 ETF10

052 041 03 007 03 013 005
058 043 046 054 004 027 041 021
1.00 0.80 0.70 0.65 0.51 0.64 013 0.36
EF04 047 043 08 100 050 053 038 048 016 014
ETFO5 041 046 070 050 100 044 054 052 017 02
ETF06 032 0.54 0.65 0.53 0.44 1.00 0.25 045 0.15 0.07
ETFO7 007 004 051 038, 03 025 100 077 020 020
ETF08 023 027 064 048 052 045 077 100 010 0L
EF09 013 011 013 016 017 015 020 010 100 015
014 025 007 020 012 015 100
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Now, once we have the annualized rate of return that will give us an idea about average return
and average risk to be expected from individual assets individual ETFs. Next comes the pair
wise correlation. So, we will calculate the pair wise a correlation or across correlation or
across securities across ETFs. We know the correlation formula here for example, if we
implement this formula in excel, we know that the correlation can be calculated by using this

formula where x is series 1 and y is series 2 or observation 2.

So, if we have 2 data series x and y then we can calculate by implementing this formula to
find the correlation or pair wise correlation for the data set that we have. This is the
correlation that we can generate. We can see here that for correlation between ETF1 and

ETF1 its 1. Similarly, for ETF2 and ETF2 it is 1 and so on. So, if we look at the correlation



between ETF1 and ETF2, then it is 0.52. If it is correlation between ETF1 and ETF3 it is
0.52. If it is correlation between ETF4 and ETF1, then we have 0.47 and so on.

So, in this way we can have the pair wise correlation across correlation across 10 securities
that we have. Once we have the correlation the next step that we need to implement is

covariance.
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Co-variances (pair-wise) across assets/securities CovVy y =

N-1
s
oy full
=COVAR(SN$3:5N$62, N3:N62)*12 mmr
—_— A%

F02 ETFO3 ETFO4 ETFO5S ETFO6 ETFO7 ETFO8 ETF09 ETF10 Wﬂ
0.0063 00103 00104 00102 00092 00004 00016 00007 -00005
00218 00158 00132 00156 00216 00004 00026 00008 00028
00158 00343 00303 00267 00326 00055 00080 00012 00061
00132 00303 00421 00234 00291 00046 00085 00016 00026
ETFO5 00102 00156 00297 00234 00525 00278 00072 00079 00020 00052
ETF06 00092 00216 00326 00291 00273 00727 00040 00081 0.0020 00018
ETFO7 00004 00004 00055 00046 00072 00040 00034 00030 00006 00010
ETF08 00016 00026 00080 00086 00079 00081 00030 00045 00003 00007
ETF09  .00007 00008 00012 0.0016 0.0020 00020 0.0006 00003 0.0025  0.0007
0.0028 00061 00026 00052 00018 00010 00007 00007 00082
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Now, covariance formula is pretty straightforward. Here we know that if we have 2 data
series where x and y are 2 data series then we can calculate the covariance between x and y by
implementing this particular formula. And here we have the covariance of all the 10 securities

or 10 ETFs calculated as follows.



If we are implementing this particular example in an spread sheet then we know that we can
use the function covar for these data points that is N3 through N62 which is basically the
return for asset ETF1 for the entire period. And similarly, we can use this function for
calculating the covariance between ETF1 and ETF1, similarly ETF1 and ETF2, ETF1 and
ETF3 and so. Now, we have average rate of average return, we have average risk, we have

correlation and we have covariance.

Now, with all this can be implement in Excel for example, the portfolio theory or the
approach through which we can find how much of investment, how much of money of total
pool or total fund should be invested in ETF1 and ETF2 and 3 and 4 throughout 10. So, that
we can either have the maximum return as an investor or we can have the minimum risk.
Remember as an investor our dream our goal is to achieve maximum return for the minimum

risk, but both typically is not achieved together.

So, we can achieve, we can obtain a portfolio, we can construct a portfolio of assets which
will give us maximum return for a given level of risk or minimum risk for an expected level
of return. From our understanding of portfolio theory, we know that if we are sure about what
return to expect then we can using portfolio theory we can figure out what will be the

minimum risk that I need to assume if I want to achieve that rate of return.

Similarly, if I know about how much risk I can bear, what is the maximum risk that I can
tolerate then using portfolio theory we can figure out what will be the maximum return that |
need to ask for. So, here we have all the ingredients average return, average risk correlation,

covariance.
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= Finding the weight of individual securities to be included in the portfolio through Solver (add-in)

= First: activate ‘Solver Add-in’ in the Excel program, if not done already:

»  File > Options > Add-in > Go...
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And now we will proceed further for implementing this example in a portfolio theory. Now,
the task of a portfolio theory is twofold. One to quantify the relationship between risk and
return which means to tell us how much extra return should be asked for every unit of risk or
every unit of additional risk that we are assuming. So, if I move from 1 unit of risk to 2 unit

of risk what should be my expectation in terms of extra return?

If we remember in portfolio theory we have learned that if this is the risk that I have I can
carry and we know that the portfolio theory suggest about something like this where we have
this kind of relationship this is a frontier of risky asset, this is risk free asset and this
particular curve. So, this is the curve that tells us about the frontier of risky asset and this

basically is risk free asset and when we combine risk free asset with risky asset this is the



frontier that we obtain and if we move along this frontier this curve, we get a portfolio that

will have exposure to both risky assets and risk free asset.

So, if we know that as an investor I have this much of risk tolerance or this much this is the
risk that I need to I can bear then this portfolio theory tells us that this is the maximum return
that I can earn. Similarly, if we know that this is the risk this is the maximum risk that I can
bear then this is the maximum return that I have to expect if we combine both risky assets and
risk free asset and if we do not combine risk free asset then this is the return that I have to

accept if this is if this is my level of risk tolerance.

So, this is the first task of portfolio theory. Second task of a portfolio theory is tell us in what
proportion funds should be invested or should be allocated across different assets available
for investment such that investor is able to achieve either return maximization objective or
risk minimization objective. So, second task of a portfolio theory is to find the weight of

individual securities that are going to be included as part of the portfolio.

Now, here we are going to use this this data to find the weight of individual ETFs that are
included in the portfolio through solver that is an add in. So, if you have not gone through it
before then I would request you to see if you can activate solver add in beforehand and in the

excel program and then you can proceed further.
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Finding the weight of individual securities to be included in the portfolio through Solver (add-in)

First: activate ‘Solver Add-in’ in the Excel program, if not done already:

File > Options > Add-in > Go...

Then, Include ‘Solver Add-in’ > 0K

Addins X
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So, to add this solver add in in the excel program we go to file, then option, then add in and
go and here we have this this type of window where we have excel add in and we go with this
excel add in that gives us a solver add in along with other options. So, if we use this solver
add in and subsequently, we can just click on ok and figure out that solver add in is added
here. Now, with this we are ready to repeat this exercise or implement this example of finding

weights of individual ETFs that are to be included in the portfolio.
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: 1
* Recall the n-asset Markowitz problem:  minimize — WiW;0;j
2

ij=1
n n

subiectta:Zwiﬁ:f, and Zwi:l’
i=1 i=1

Now, let us recall the n asset Markowitz portfolio theory or Markowitz problem. Remember
typically our investor wants to minimize the risk. So, when we try to minimize the risk

basically its minimizing the total risk of the portfolio which comprises of asset 1 and j.

So, we use this objective function of minimization of total risk subject to certain constraints
and these constraints are in whatever proportion we us allocate the asset across allocate the

budget allocate the funds across different assets it should give us a desired rate of return.

So, we want to minimize the risk for a given level of return. Remember that example the
scenario where we have efficient frontier and we want to minimize the risk for a given level
of return. Suppose an investor says that this is the return that [ want to earn. So, what will be

the minimum risk that I need to bear?



So, this task is done by portfolio theory. So, it asks the optimizer to minimize the risk for the
portfolio subject to the return constraint that is return should be the return on the portfolio
should be the weighted average rate of return for individual securities and 100 percent weight
100 percent of the funds should be allocated to different assets as part of the portfolio. So, the

sum total of all the individual weights should be equal to 1.
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* Recall the n-asset Markowitz problem:  minimize _z WiW;0;j
2

ij=1
i n

subjectta:Zwﬁ:i, and ZWFL
=1 i=1

* Here, let’s allow the portfolio weight vector w to take on any real value, but
sometimes we’d restrict the portfolio weights, by adding more constraints to
the above objective function.

* Ifwedemandw; > 0,i = 1,2, ..., n, then we do not allow short-selling.

* |fwe demand w; € [I;,u;],i = 1,2,..., n, then we require the portfolio
weight w; to lie between the lower and upper boundary /; and u,,

respectively..
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Now, with this here we know that we if we allow the portfolio weight vector W to take any
real value, but sometimes we would restrict the portfolio weights by adding more constraint
to the above objective function and if we demand weight of individual securities being greater
than equal to 0 where individual securities could be 1, 2, 3, n that we do not then then we
know that we are not allowing short selling which means we are putting the constraint of not

having non-negative weight, negative weights.



So, essentially, we mean to say that we do not want to have any negative weights rather all
weight should be 0 or greater than 0. Similarly, if we demand another function then we
require the portfolio weight w to lie between lower and upper boundary | and u respectively.
So, yeah if we have this these conditions, we can put these constraint and subsequently we

can find the value of w for irrespective assets.
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: 1
* Recall the n-asset Markowitz problem:  minimize _z WiW;0;;
2
ij=1
i n

subject to: Zwiﬁ- =7, and Zwi =1,
i=1 i=1

* Here, T is the desired level of expected rate of return (on the portfolio).

15 . 2 s
* The factor; is a scaling factor in order to get nicer/simpler formula.
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Here r that is the expected rate of return it desired or expected rate of return on the portfolio

and factor 1 by 2 is scaling factor in order to get nicer simpler formula.
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=  Finding the weight of individual securities to be included in the portfolio through Solver (add-in)

) W% 0% 1% 106 1% 0% 10% 1
e

i)"fi
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So, we know already about this Markowitz portfolio theory and using this argument we are
trying to find the weight of individual securities that we want to include in the portfolio and
here this is the way we calculate the weight. So, what we do here is in this particular table we
start with 10 ETFs ETF 1 through ETF 10 and to begin with we have one equally weighted
portfolio where 10 percent each is invested or allocated to the 10 ETFs that we have which

mean total weight should be 100.

This particular column indicates about the target return of whatever percentage of return that
we expect from the investment in portfolio and this return should be basically a function of
average rate of return or just recalling from previous calculation annualized rate of return of

individual ETFs multiplied with these percentage or these weights of individual securities.



So, remember the weight i into r i where r 1 is annualized rate of return and weight here for
the time being is given as 10 percent each, but we will try to optimize it we will try to change
this and this will be sum together to find this rate of return and this is the standard deviation

that we want to reduce we want to minimize.
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Finding the weight of individual securities to be included in the portfolio through Solver (add-in)

Target Retun StdDev Return | ETFO1 ETFO2  ETFO3 ETF04 ETFO5 ETFO6 ETFO7  ETFO8  ETFO9  ETF10 |Total Weight

+ Objective Function: Minimization of StdDev (Data > Solver (under Analyze) > Set Objective > Min)
« Constraints: Target Return; Non-negative weights; Total weight being 1.
« In Solver: Data > Solver (under Analyze) > By Changing Variable Cells: $AB$31:$AK$31

+ In Solver: Data > Solver (under Analyze) > Subject to the Constraints:
+ $AA$31 = §Y$31 (Target Return)
+ $AB$31:$AK$31 <=1 (No weight more than total fund available)
+ $AB$31:3AK$31 <=0 (No short-selling/negafive weighty
+ $AL$31=1 (Total of welghts being 1)
St v St S Sl P
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So, what we do here is we put the objective function of minimization of standard deviation
that is if we are implementing this example in excel sheet, we use the datas data option data
tab to go to solver under analyze then we have an option set objective and we have the option
to minimize that minimization of objective. And then we put the constraint the constraints are
target return that is whatever return we are want to achieve non-negative weights and total

weights or sum total of individual weight should be 1.



So, in solver we put the data tab go to solver under analyze then by changing variables sales
of a particular set of sales which is basically nothing, but the weight assigned to individual
ETFs. So, to start with we will have a by default weight of 10 percent each, but we want to

change this by using this solver.

Now, we also have to put constraint and the constraint will be in solver we go to data tab
solver under analyze function then subject to constraint where we will put the constraint such

that the target return should be return that we are here.

So, this particular return should be equal to this particular return that we have decided. So,
second constraint is about the weight being not more than 1 which implies that we cannot
invest more than 100 percent of the money. Third constraint is about non-negative weights
which is basically we cannot allow short selling and finally, the last constraint is about total

sum total of individual weight should be 1 or 100 percent of the funds available.

With these constraints and objective function, we will go ahead with implementing this in

solver where we have all the constraint and objective function written.
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*  Finding the weight of individual securities to be included in the portfolio through Solver (add-in)

+ C ints: Target Return; N gative weights; Total weight being 1.

+ In Solver: Data > Solver (under Analyze) > By Changing Variable Ce| $ABS31:$AK$31

Min: $Z$31

The Constraints:

+ $AAS31 = $Y$31

+ $AB$31:5AK$31 <=1
+ $AB$31:5AKS$31 <=0
+ $AL$31 =1
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So, here we have the objective function which is the minimization of standard deviation then
we have by changing the sales particularly changing the weights and then we have the
constraint that are in input given here and with this we solve this and the for further results we

will discuss in next session.
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CONCLUSIONS

* ETFs are taken as a set of assets that can be combined to form a portfolio to
achieve minimum risk (for an expected return) or maximum return (for a given
level of risk);

* Five year monthly data on ten securities are used for demonstrating the
portfolio formation using spreadsheet example.

* Under certain constraints, we aim to solve for the objective function using
Solver (as a used case here).
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So, so far in in this session we know that ETFs are one of the emerging asset classes and
using ETF data as a set of assets we that can be combined to form a portfolio we are going to

implement.

This as an a portfolio optimization exercise using excel solver where we have the five year
monthly data on ten ETFs that are used for demonstrating this portfolio formation using
objective function constraint and we try to find the optimal weight that can be assigned to

individual ETFs to minimize the risk of the portfolio. With this I end up this session.
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+  Introduction to Exchange Traded Funds (ETFs) - CDSL
https://etf.nipponindiaim.com/#etfmodelportfolio
https://www.nseindia.com/market-data/exchange-traded-funds-etf
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Thank you very much.



